re = /^(?:3[47]|(\d{2}))\d{13}$/m
str = '331234567890123
141234567890123
971234567890123
341234567890123
371234567890123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end