$re = '/^[a-z][a-z0-9_]*(\.[a-z0-9_]+)*[a-z0-9_]*$/m';
$str = 'a
ab
ab_
a.b
a._
a.1
a_0.b
a_0.b_
a_._
a.1._
a._.1
a.1.b
a.b._
java.awt.event
.
..
.g
.1
1.
._
_.
0
0a
_1
_a
a.b.
a.
a.0.
a._.
javax.swing.JFrame
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);