import Foundation
let pattern = #"^[a-z][a-z0-9_]*(\.[a-z0-9_]+)*[a-z0-9_]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a
ab
ab_
a.b
a._
a.1
a_0.b
a_0.b_
a_._
a.1._
a._.1
a.1.b
a.b._
java.awt.event
.
..
.g
.1
1.
._
_.
0
0a
_1
_a
a.b.
a.
a.0.
a._.
javax.swing.JFrame
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)