using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Text\([^)]*\)(?:(?!\.appFont)[^}])*}";
string input = @"Text(""blah"")
.appFont(.body)
}
Text(""blah"")
}
Text(
""blah""
)
.appFont(.blah)
}
Text(""blah"").appFont(.foo)}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}