re = /Text\([^)]*\)(?:(?!\.appFont)[^}])*}/m
str = 'Text("blah")
.appFont(.body)
}
Text("blah")
}
Text(
"blah"
)
.appFont(.blah)
}
Text("blah").appFont(.foo)}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end