$re = '/^\+[0-9]{12}$/m';
$str = '+123456789001
+1234567890011
123456789001
1234567890011';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);