re = /^\+[0-9]{12}$/m
str = '+123456789001
+1234567890011
123456789001
1234567890011'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end