package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[~#^/<>]`)
var str = `abc^ 123 # //> <`
var substitution = "~$0"
fmt.Println(re.ReplaceAllString(str, substitution))
}