$re = '@[~#^/<>]@';
$str = 'abc^ 123 # //> <';
$subst = "~$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;