$re = '/\b(?!HVAC|AC)(?<upper>[\w])(?<lower>[\w]+)\b/m';
$str = 'this is an HVAC AC converter';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);