re = /\b(?!HVAC|AC)(?<upper>[\w])(?<lower>[\w]+)\b/m
str = 'this is an HVAC AC converter'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end