$re = '#\[a:section(.*)\](.*)\[\/a:section\]#';
$str = '[a:section asasasas][a:widget type=blog][a:widget type=blog][a:widget type=blog][/a:section]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);