re = /\[a:section(.*)\](.*)\[\/a:section\]/
str = '[a:section asasasas][a:widget type=blog][a:widget type=blog][a:widget type=blog][/a:section]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end