#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\G(?!\A)[^\w\n]+|X\s+)(\w+)"
Local $sString = "X abc, abd." & @CRLF & _
"X abc, abd, abcd." & @CRLF & _
"X abc abd, abc." & @CRLF & _
"X asdas, asdasd, adsasda, asdasda." & @CRLF & _
"X asdas asdasda, asdasdas asdasda, asdasdasas, asdasddas."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")