import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!\\A)[^\\w\\n]+|X\\s+)(\\w+)";
final String string = "X abc, abd.\n"
+ "X abc, abd, abcd.\n"
+ "X abc abd, abc.\n"
+ "X asdas, asdasd, adsasda, asdasda.\n"
+ "X asdas asdasda, asdasdas asdasda, asdasdasas, asdasddas.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}