#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:DHI?-)?(?:IPC|HAC)-HDB?W\d+[A-Z]+\K(?:P-0\d{1,2}|P)"
Local $sString = "DH-HAC-HDBW3802EP-Z" & @CRLF & _
"DH-HAC-HDBW3802EP-ZH" & @CRLF & _
"DH-HAC-HDW1000MP-028" & @CRLF & _
"DH-HAC-HDW1000RP-028" & @CRLF & _
"DH-HAC-HDW1100EMP-02" & @CRLF & _
"DH-HAC-HDW1100EMP-03" & @CRLF & _
"DH-HAC-HDW1100MP" & @CRLF & _
"DH-HAC-HDW1100MP-036" & @CRLF & _
"DH-HAC-HDW1100RP-028" & @CRLF & _
"DH-HAC-HDW1100RP-VF" & @CRLF & _
"DH-HAC-HDW1100AP-028" & @CRLF & _
"DH-HAC-HDW1100AP-036" & @CRLF & _
"DH-HAC-HDW1100AP" & @CRLF & _
"DH-HAC-HDW1100BP-028" & @CRLF & _
"DH-HAC-HDW1100BP-036" & @CRLF & _
"DH-HAC-HDW1100BP" & @CRLF & _
"DH-HAC-HDW1100CP-" & @CRLF & _
"DH-HAC-HDW1100DP-036" & @CRLF & _
"DH-HAC-HDW1100DP-" & @CRLF & _
"DH-HAC-HDW1100EMP-03" & @CRLF & _
"DH-HAC-HDW1100EMP-02" & @CRLF & _
"DH-HAC-HDW1100EMP-" & @CRLF & _
"DH-HAC-HDW1100EP-036" & @CRLF & _
"DH-HAC-HDW1100EP-028" & @CRLF & _
"DH-HAC-HDW1100EP-03" & @CRLF & _
"DH-HAC-HDW1100EP-02" & @CRLF & _
"DH-HAC-HDW1100EP-" & @CRLF & _
"DH-HAC-HDW1100EP" & @CRLF & _
"DH-HAC-HDW1100FP-03" & @CRLF & _
"DH-HAC-HDW1100FP-02" & @CRLF & _
"DH-HAC-HDW1100FP-" & @CRLF & _
"DH-HAC-HDW1100FP" & @CRLF & _
"DH-HAC-HDW1100RMP-03" & @CRLF & _
"DH-HAC-HDW1100RMP-02" & @CRLF & _
"DH-HAC-HDW1100RMP-" & @CRLF & _
"DH-HAC-HDW1100RMP" & @CRLF & _
"DH-HAC-HDW1100RP-028" & @CRLF & _
"DH-HAC-HDW1100RP-036" & @CRLF & _
"DH-HAC-HDW1100RP-" & @CRLF & _
"DH-HAC-HDW1100RP" & @CRLF & _
"DH-HAC-HDW1100SP-036" & @CRLF & _
"DH-HAC-HDW1100SP-028" & @CRLF & _
"DH-HAC-HDW1100SP-" & @CRLF & _
"DH-HAC-HDW1100SP" & @CRLF & _
"DH-HAC-HDW1100SLP-03" & @CRLF & _
"DH-HAC-HDW1100TP-" & @CRLF & _
"DH-HAC-HDW1100MP-036" & @CRLF & _
"DH-HAC-HDW1100MP-028" & @CRLF & _
"DH-HAC-HDW1100MP" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)