# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:DHI?-)?(?:IPC|HAC)-HDB?W\d+[A-Z]+\K(?:P-0\d{1,2}|P)"
test_str = ("DH-HAC-HDBW3802EP-Z\n"
"DH-HAC-HDBW3802EP-ZH\n"
"DH-HAC-HDW1000MP-028\n"
"DH-HAC-HDW1000RP-028\n"
"DH-HAC-HDW1100EMP-02\n"
"DH-HAC-HDW1100EMP-03\n"
"DH-HAC-HDW1100MP\n"
"DH-HAC-HDW1100MP-036\n"
"DH-HAC-HDW1100RP-028\n"
"DH-HAC-HDW1100RP-VF\n"
"DH-HAC-HDW1100AP-028\n"
"DH-HAC-HDW1100AP-036\n"
"DH-HAC-HDW1100AP\n"
"DH-HAC-HDW1100BP-028\n"
"DH-HAC-HDW1100BP-036\n"
"DH-HAC-HDW1100BP\n"
"DH-HAC-HDW1100CP-\n"
"DH-HAC-HDW1100DP-036\n"
"DH-HAC-HDW1100DP-\n"
"DH-HAC-HDW1100EMP-03\n"
"DH-HAC-HDW1100EMP-02\n"
"DH-HAC-HDW1100EMP-\n"
"DH-HAC-HDW1100EP-036\n"
"DH-HAC-HDW1100EP-028\n"
"DH-HAC-HDW1100EP-03\n"
"DH-HAC-HDW1100EP-02\n"
"DH-HAC-HDW1100EP-\n"
"DH-HAC-HDW1100EP\n"
"DH-HAC-HDW1100FP-03\n"
"DH-HAC-HDW1100FP-02\n"
"DH-HAC-HDW1100FP-\n"
"DH-HAC-HDW1100FP\n"
"DH-HAC-HDW1100RMP-03\n"
"DH-HAC-HDW1100RMP-02\n"
"DH-HAC-HDW1100RMP-\n"
"DH-HAC-HDW1100RMP\n"
"DH-HAC-HDW1100RP-028\n"
"DH-HAC-HDW1100RP-036\n"
"DH-HAC-HDW1100RP-\n"
"DH-HAC-HDW1100RP\n"
"DH-HAC-HDW1100SP-036\n"
"DH-HAC-HDW1100SP-028\n"
"DH-HAC-HDW1100SP-\n"
"DH-HAC-HDW1100SP\n"
"DH-HAC-HDW1100SLP-03\n"
"DH-HAC-HDW1100TP-\n"
"DH-HAC-HDW1100MP-036\n"
"DH-HAC-HDW1100MP-028\n"
"DH-HAC-HDW1100MP\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.