// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".{8}").unwrap();
let string = "asd asd asd asd asd asd asd asd asd asd asd asd asd asd sd
asdfasdfasdfasdfasdf asdas asd
3 4 8 9567678589,.,.,.,.,.,.,.,.,.,.,adsnasdashd kajshdkahsd aksdhkadsh
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}