import Foundation
let pattern = #".{8}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
asd asd asd asd asd asd asd asd asd asd asd asd asd asd sd
asdfasdfasdfasdfasdf asdas asd
3 4 8 9567678589,.,.,.,.,.,.,.,.,.,.,adsnasdashd kajshdkahsd aksdhkadsh
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)