$re = '/\/\*\*(.*?)\*\/\w+\d+/';
$str = '/**word1*/asdf /**word2*/abc123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);