$re = '/(?<!\S)[A-Za-z]+(?!\S)/';
$str = 'test test3 t3st test: word%5 test! testing t[st';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);