re = /(?<!\S)[A-Za-z]+(?!\S)/
str = 'test test3 t3st test: word%5 test! testing t[st'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end