using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-(.*?)_";
string input = @"adapter-UDP02_sistem10_a.log";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}