$re = '/\b([a-zA-Z]+)(?: [a-zA-Z]+%.*?)? (\d+(?:\.\d+)?)(?!\S)/m';
$str = 'Fluid 13.4
Fluid 13.4 gm% fluid_haemo 12.0-14.0
Fluid gm% 13.4 fluid_haemo 12.0-14.0
Fluid gm% fluid_hameo 12.0-14.0 13.4
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);