import Foundation
let pattern = #"\b([a-zA-Z]+)(?: [a-zA-Z]+%.*?)? (\d+(?:\.\d+)?)(?!\S)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Fluid 13.4
Fluid 13.4 gm% fluid_haemo 12.0-14.0
Fluid gm% 13.4 fluid_haemo 12.0-14.0
Fluid gm% fluid_hameo 12.0-14.0 13.4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)