# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((([13578]|0[13578]|1[02])\/([1-9]|0[1-9]|[12][0-9]|3[01]))|(([469]|0[469]|11)\/([1-9]|0[1-9]|[12][0-9]|30))|((2|02)\/([1-9]|0[1-9]|1[0-9]|2[0-9])))$"
test_str = ("02/02\n"
"02/12\n"
"02/29\n"
"02/29\n"
"06/31\n"
"01/31\n"
"02/02\n"
"02/02\n"
"02/02\n"
"02/02\n"
"02/02\n"
"02/02\n"
"01/01")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.