import Foundation
let pattern = #"^((([13578]|0[13578]|1[02])\/([1-9]|0[1-9]|[12][0-9]|3[01]))|(([469]|0[469]|11)\/([1-9]|0[1-9]|[12][0-9]|30))|((2|02)\/([1-9]|0[1-9]|1[0-9]|2[0-9])))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
02/02
02/12
02/29
02/29
06/31
01/31
02/02
02/02
02/02
02/02
02/02
02/02
01/01
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)