$re = '/\(([^)]*)\)/';
$str = '(1, \'AC\', \'Acre\'), (2, \'AL\', \'Alagoas\'), (3, AM, \'Amazonas\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);