re = /\(([^)]*)\)/
str = '(1, \'AC\', \'Acre\'), (2, \'AL\', \'Alagoas\'), (3, AM, \'Amazonas\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end