package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^C+$`)
var str = `ABC
ACB
CAB
CAC
CCC CCC
CCC
CC
C
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}