import re
regex = re.compile(r"(\d{4}(-\d{2}-\d{2}|\d{2}\d{2}))(T\d{2}(:?\d{2}){1,2}(\.\d{1,3})?(([+-]\d{2}(:?\d{2})?)|Z)?)?", flags=re.MULTILINE)
test_str = ("2001-01-20\n"
"20010120\n"
"2001-0120\n\n"
"2001-01-20T01:20\n"
"2001-01-20T01:20:30\n"
"2001-01-20T01:20:30Z\n"
"2001-01-20T01:20:30+0500\n"
"2001-01-20T01:20:30.000Z\n"
"2001-01-20T01:20:30+00:50\n"
"2001-01-20T01:20:30-00:50\n\n\n"
"20010120T0120\n"
"2001-01-20T012030Z\n"
"2001-01-20T0120+0500\n"
"2001-01-20T01:20:30.000Z\n"
"2001-01-20T01:20:30+00:50\n"
"2001-01-20T01:20:30-00:50")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")