re = /(\d{4}(-\d{2}-\d{2}|\d{2}\d{2}))(T\d{2}(:?\d{2}){1,2}(\.\d{1,3})?(([+-]\d{2}(:?\d{2})?)|Z)?)?/m
str = '2001-01-20
20010120
2001-0120
2001-01-20T01:20
2001-01-20T01:20:30
2001-01-20T01:20:30Z
2001-01-20T01:20:30+0500
2001-01-20T01:20:30.000Z
2001-01-20T01:20:30+00:50
2001-01-20T01:20:30-00:50
20010120T0120
2001-01-20T012030Z
2001-01-20T0120+0500
2001-01-20T01:20:30.000Z
2001-01-20T01:20:30+00:50
2001-01-20T01:20:30-00:50'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end