package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?i)the) cat`)
var str = `the cat
The cat
THE cat
the Cat
the CAT`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}