$re = '/((?i)the) cat/m';
$str = 'the cat
The cat
THE cat
the Cat
the CAT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);