package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[CDFGIMP][^_\\s]*_\\S*`)
var str = `C_12345`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}