const regex = /^[CDFGIMP][^_\\s]*_\\S*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[CDFGIMP][^_\\\\s]*_\\\\S*', '')
const str = `C_12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}