import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^\\t]+\\s|\\t|\\w$)";
final String string = "0828041930 72 0:5493513263615:1:1 0:3513263615:2:1 0:5491124970159:1:1 0 9 14 841 SMPP.841:1 1.0 0 0 20210712160302 20210712160302 1 -1 0 none/dfl (0) 10000 0 eng/dfl (1) 1440 D 0 M 72 1 1 1 0:543200160020:1:1:722310033349388 3 2 1 MAP.1:1 1.0 1 -1 0 0 0 0 0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}