use strict;
my $str = '0828041930 72 0:5493513263615:1:1 0:3513263615:2:1 0:5491124970159:1:1 0 9 14 841 SMPP.841:1 1.0 0 0 20210712160302 20210712160302 1 -1 0 none/dfl (0) 10000 0 eng/dfl (1) 1440 D 0 M 72 1 1 1 0:543200160020:1:1:722310033349388 3 2 1 MAP.1:1 1.0 1 -1 0 0 0 0 0';
my $regex = qr/(?:[^\t]+\s|\t|\w$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}