package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\p{P}\p{S}\s\d]+`)
var str = `win32 backdoor guid:64664646 DNS-lookup h0lla`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}