$re = '/[^\p{P}\p{S}\s\d]+/m';
$str = 'win32 backdoor guid:64664646 DNS-lookup h0lla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);