import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(if ?\\(.*(?P<v1>\\bvariavel\\b))|(^let (?P<v2>variavel) = )|^[\\t ]*?(?P<v3>variavel)[. ]|\\(.*?(?P<v4>\\bvariavel\\b).*?\\)|(.*?\\$\\{.*?(?P<v5>\\bvariavel[. ]?\\b))|(.*?[\\'\\\"]\\s*?\\+\\s*?\\b(?P<v6>variavel)\\b)+?";
final String string = "if(variavel == true)\n\n"
+ "if(modelo == variavel)\n\n"
+ "let variavel = \"asduasdtu\"\n\n"
+ "variavel = true\n\n"
+ " variavel.adsahg = \"ghhjgkhjg variavel \"\n\n"
+ "variavel.fn(variavel)\n"
+ "`${alguma coisa variavel.\n\n"
+ "'ashgdjas\" + variavel.asdkjhk + sdjkahkld\" + variavel";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}