const regex = new RegExp('(if ?\\(.*(?P<v1>\\bvariavel\\b))|(^let (?P<v2>variavel) = )|^[\\t ]*?(?P<v3>variavel)[. ]|\\(.*?(?P<v4>\\bvariavel\\b).*?\\)|(.*?\\$\\{.*?(?P<v5>\\bvariavel[. ]?\\b))|(.*?[\\\\'\\"]\\s*?\\+\\s*?\\b(?P<v6>variavel)\\b)+?', 'gm')
const str = `if(variavel == true)
if(modelo == variavel)
let variavel = "asduasdtu"
variavel = true
variavel.adsahg = "ghhjgkhjg variavel "
variavel.fn(variavel)
\`\${alguma coisa variavel.
'ashgdjas" + variavel.asdkjhk + sdjkahkld" + variavel`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}