# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"http:\/\/mywebsite\.com\/((?:http:\/\/)?[0-9A-Za-z]+(?:-+[0-9A-Za-z]+)*(?:\.[0-9A-Za-z]+(?:-+[0-9A-Za-z]+)*)+(?:\/.*)?)"
test_str = ("http://mywebsite.com/google.com/search=xyz\n"
"http://mywebsite.com/yahoo.org/search=xyz\n"
"http://mywebsite.com/www.yahoo.org/search=xyz\n"
"http://mywebsite.com/msn.co.uk\n"
"http://mywebsite.com/http://msn.co.uk\n"
"http://mywebsite.com/badname/\n"
"http://mywebsite.com/test.com/ww\n"
"http://mywebsite.com/-badname.com\n"
"http://mywebsite.com/tes-t.com/ww")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.