re = /http:\/\/mywebsite\.com\/((?:http:\/\/)?[0-9A-Za-z]+(?:-+[0-9A-Za-z]+)*(?:\.[0-9A-Za-z]+(?:-+[0-9A-Za-z]+)*)+(?:\/.*)?)/
str = 'http://mywebsite.com/google.com/search=xyz
http://mywebsite.com/yahoo.org/search=xyz
http://mywebsite.com/www.yahoo.org/search=xyz
http://mywebsite.com/msn.co.uk
http://mywebsite.com/http://msn.co.uk
http://mywebsite.com/badname/
http://mywebsite.com/test.com/ww
http://mywebsite.com/-badname.com
http://mywebsite.com/tes-t.com/ww'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end