const regex = /(?:^|\b)(\d{5}-\d{4}|\d{5})\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\b)(\\d{5}-\\d{4}|\\d{5})\\b', 'g')
const str = `12345
43245 90210
sdf 11111 asf
1
12
123
1234
123456
12345-12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}