$re = '/(?:^|\b)(\d{5}-\d{4}|\d{5})\b/';
$str = '12345
43245 90210
sdf 11111 asf
1
12
123
1234
123456
12345-12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);