package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)A\d{2}0|B7\d7`)
var str = `Brought my Sony A5000 for my trip
the Airbus A220v300's bathroom has a window
My favorite jet is the B737-900ER flew it like x 239
all stan the queen B747, 120% the B333st
I like the chonky A380
but I love the A350`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}