# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"A\d{2}0|B7\d7"
test_str = ("Brought my Sony A5000 for my trip\n"
"the Airbus A220v300's bathroom has a window\n"
"My favorite jet is the B737-900ER flew it like x 239\n"
"all stan the queen B747, 120% the B333st\n"
"I like the chonky A380\n"
"but I love the A350")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.