import re
regex = re.compile(r"(A[23]\d0|B7\d7)$", flags=re.MULTILINE)
test_str = ("Brought my Sony A5000 for my trip\n"
"the Airbus A220v300's bathroom has a window\n"
"My favorite jet is the B737-900ER flew it like x 239\n"
"all stan the queen B747, 120% the B333st\n"
"I like the chonky A380\n"
"but I love the A350")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")