re = /(A[23]\d0|B7\d7)$/m
str = 'Brought my Sony A5000 for my trip
the Airbus A220v300\'s bathroom has a window
My favorite jet is the B737-900ER flew it like x 239
all stan the queen B747, 120% the B333st
I like the chonky A380
but I love the A350'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end